Frontu application server #1 DOWN

Incident Report for Frontu

Resolved

On the morning of 5 July 2026 (UTC), one of our production application tiers experienced sustained high memory usage. This caused slow responses, timeouts, and intermittent errors for some Client API consumers served by that tier. Web application users may have noticed occasional slowness during the same period.

The root cause was a defect in how our Client API handled single-record lookup requests that contained no valid filter parameter. An external integration was unintentionally sending requests of exactly this shape in a retry loop, which multiplied the effect.

A fix was developed, tested, and released the same day. No customer data was lost, altered, or exposed to any other account.
Posted Jul 06, 2026 - 11:36 EEST

Investigating

We are currently investigating this issue.
Posted Jul 05, 2026 - 10:14 EEST